Launcher stuck



  • Hello, i almost finished downloading the game and now the launcher is stuck at 222.3MB out of 224.7MB.
    At first it was going ok, then when he arrived at that point the download speed started to go down, and now it’s at 0b/s.
    I tried to repair the client, i did remove cache, clear game logs, tried to download it to another pc, moving the entire crimson folder to another drive on pc, added the game to firewall/antivirus exclusions, nothing works…Any idea why this happens? it’s like that since 6h ago…should i just dump the idea of playing it?!Screenshot_2.png
    Which launcher are you using? - the one that i downloaded yesterday from the website, should be the live one.
    Which operating system are you running? -Windows 10
    Is your operating system x64 or x86? -64-bit
    Have you attempted restarting your system? - Yes
    A description of the issue which you are facing. -As above
    Steps to reproduce. - Just press install xD


  • Gamemaster

    @c1a3456 Hello! Could you try to start the Game through the folder and not from the Shortcut?



  • @HoaqinSnowix your method to start from game folder dont work … tryed it yesterday and its conformed

    @c1a3456 just exit luncher and enter and tap install

    Repet until it will finish

    I instelled game yesterday and can conformed that its working



  • @eran702 i see, so i just have to retry until it works xD fine fine…
    ty for the reply :)



  • @HoaqinSnowix not working, same stuff happens…and loading the launcher from the folder doesn’t give any benefit, it’s not like the shortcut is bugged or it has some added commands to it, it’s the exact copy of the one inside the folder. ty tho for the reply